Fernwartungsmodul herunterladen

32bit Pakete auf 64bit CentOS

Ich bin eben über ein Problem gestolpert beim Installieren von 32bit Paketen auf einer 64bit CentOS-Installation. Es gibt kein exaktes Äquivalent zu den "ia32-libs" in Debian, deswegen war ich etwas verwirrt über folgende Fehlermeldung.

Error: Protected multilib versions: openssl-1.0.0-10.el6_1.5.i686 != openssl-1.0.0-10.el6.x86_64
You could try using –skip-broken to work around the problem
You could try running: rpm -Va –nofiles –nodigest

Die Lösung war sehr einfach:

yum update

danach

yum install openssl.i86

Im Prinzip war der Trick erst durch "update" ie VErsion anzugleichen und DANN erst die 32bit-Version in PASSENDER Version einzuspielen.